Jump to content
Sign in to follow this  
jb919119

custom game world not showing up on my profile after I paid for it

Recommended Posts

Okay guys so I bought a custom world and never got an ID to access my world, and it never showed on my profile as it was supposed to. I later realized my gold membership had expired and I need to be a gold manager to have a custom world. I then proceeded to pay a gold membership thinking everything would go back to normal. Except it hasn't. Originally payed for a custom world on May 7 and for the gold membership on May 10. I emailedĀ support@soccermanager.com on May 7 because I couldn't understand why I didn't get the ID for my world in my receipt and haven't heard back since. I don't know what to at this point. Any help will be greatly appreciated.

Share this post


Link to post
Share on other sites
Just now, jb919119 said:

How do I do that??

At the top right of the page listing your game worlds there's an icon with three horizontal lines. Click that, then 'Help', then 'Report Bugs'.

Share this post


Link to post
Share on other sites
2 minutes ago, Kev said:

At the top right of the page listing your game worlds there's an icon with three horizontal lines. Click that, then 'Help', then 'Report Bugs'.

Just did. Hopefully they will get back to me very soon. Thank you so much!!

Share this post


Link to post
Share on other sites
6 minutes ago, jb919119 said:

Just did. Hopefully they will get back to me very soon. Thank you so much!!

Don't hold your breath... it's a bit of a lottery. Hope it gets fixed.

Share this post


Link to post
Share on other sites
9 minutes ago, Kev said:

Don't hold your breath... it's a bit of a lottery. Hope it gets fixed.

How can I file for a refund? I could do for the custom world and then pay for it again and it should work fine since i'm already a gold member. i think the bug happened because i bought the custom world while not being a gold member.

Share this post


Link to post
Share on other sites
3 minutes ago, jb919119 said:

How can I file for a refund? I could do for the custom world and then pay for it again and it should work fine since i'm already a gold member. i think the bug happened because i bought the custom world while not being a gold member.

No idea. Just cross your fingers that they get back to you. If not then email and send another bug report again. It's like getting blood out of a stone sometimes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×